I just wanna play the game but this BOSS DOESN'T SPAWN??? HELP???

Attention! We are receiving reports about SCAM attempts, which promise you to get Elcoin for free after submitting your account data on some pages.
We advise you DO NOT TO CLICK on such suspicious links and do not share your account login/password with ANYONE.
Please report any kind of such activity directly to our Support. Thank you!
  • Hello all. This is a long one and kind of a schizo rant so strap in.

    As per usual, I was sitting on my ass all day playing Elsword. Like any respectable and sexy human being, I was playing on my Ain, on the final quest that I needed to upgrade him from LW to AP. This quest wants my power-hungry ass to literally just clear the Underground Chapel in the Feita reason. Seems simple enough, and it overlaps with my story quest so its a win/win to me. So naturally I completely dominate this stage and I get to the boss. And to my disdain, the MF DIDN'T EVEN SPAWN? It's literally just the two sorcerer minion whogivesashitimgonnadieanywayscauseimfodder enemies. I figure, in my caveman brain: "durr may b the boss didn spawn yet". This seems reasonable at the time, so I oblige. I murder the sorcerers and the game says that I won. I'm thinking that that was too easy, and apparently so did the GAME ITSELF because I LITERALLY SAT THERE FOR 10 MINUTES TRYING TO CLICK ON THINGS AND NOTHING WORKED.

    I was stuck there, plain and simple, done and dusted. I couldn't even press ESC to go to the character select screen. It wouldn't even show up. I couldn't even ALT+TAB out of the game. I was stuck. It was the Elsword equivalent of laying a prostitute and, when you're about to pull out, she locks her legs around you. Not that I would know anything about that. I play Elsword, of course I don't attract any women. Eventually my hacker brain kicked in and I used ol faithful: CTRL + ALT + DELETE. I had to turn my entire damn computer off just to escape the game. And the best part is, when I booted Elsword back up and beat the level again, THE SAME. THING. HAPPENED. And the worst part is is that it never registered that the quest had been complete, so I am stuck as a LW until further notice.

    Now, I'm not asking for forgiveness. I can excuse everything that KoG has done to me since I started playing the game. I can excuse the very questionable UI changes, I can excuse them getting rid of areas such as Bethma Lake (Night) and that one Sewer System and the Suburbs in Elder as much as I enjoyed those levels (except them removing the Phoru Forest Temple thing, I still want justice for William), I can excuse the bland and frankly dogshit hubs that the more recent characters (i.e Laby, Noah, hopefully no one else) have to stay in until they reach lvl. 70 or something like that, even if they are really fun characters with satisfying and useful skills, I could forgive the changes to matchmaking... okay maybe I'm pushing it a little.

    But regardless, I could forgive ALL OF IT. But literally blocking players from progressing through the game and upgrading their characters? Isn't that what this game is about? This is a travesty to myself as an Ain enjoyer and probably some other people cause I don't know how many people experience this issue. But most importantly, it's a travesty to myself as an Elsword Veteran (circa. whenever elesis or add i think idk i was young came to the us of a). I've been playing this game, albeit on and off, for a WHILE, and it feels like they don't care about us. It feels like getting kicked in the nuts by your best friend of years and they think its a joke, while they keep laughing at you. It hurts, but it hurts more knowing that they might not care about kicking you in the proverbial balls.

    I think it's just my problem, but if it ain't they should definitely take action. While they're at it, hire a new graphic designer so that I don't have to look at that odd UI anymore, it just doesn't work with the vibe that the artstyle is going for. I'll forgive you if Ain's 4th Path doesn't suck nuts.

    TL;DR: Got stuck in the boss room while trying to upgrade Ain to 2nd Class because it never spawned, even after multiple retries.


    - Largeboss

  • Hi there largeboss,

    I have just checked the quest, and I was able to successfully complete "Crypt" (or well, Underground Chapel) and obtained the condition needed to complete "The Path of the Apostata, Part 5" and therefore, I was able to promote to Apostata with not issues whatsoever.

    If the issue for you still persist please consider sending a ticket to the support system so they can gather the information from you such as character and other information so it can be properly looked into since just for what you said, it's extremely strange that the boss does not show up for you (but it does for me) and on top of everything you get stuck.

    Also if possible, take a video (doesn't need to be a full video of the whole dungeon run, the start of the last stage until the issue happens would be enough) and either attach it to your ticket or upload it to YouTube and give the link on the ticket.


    - Senakhtenre

  • Hello there Mr. Quality Assurance Man Sir cause idk if I have the authority to tag you,

    I tried to submit a ticket. Keyword here being "tried". It redirected me to a page where it told me to log in. Thusly, I did, but it told me that my password was invalid. I'm not too sure about some other people, but I know my password, and I know that I didn't type it incorrectly. I typed it SO PERFECTLY that I might have broken a world record for slowest typing. I even used Chrome's password manager. Regardless, it gave me these robot quizzes. I don't think I'm a robot, cause I got the answers right. But I guess that wasn't enough. Eventually I caved in and changed my password. It still didn't work, and after numerous attempts at logging in, it booted me out for three hours because it thought I was a robot.

    The website led me on, and, at my most vulnerable, left me wondering if she ever loved me in the first place as she explained to me that she had been seeing a good friend of mine for months, even if she reassured me that there was no one else. Not like I'd know anything about that.

    To make a needlessly long post short, if there is an alternative option to submitting a ticket, do let me know, as I have the video footage. I just need a way to submit it without getting banned from entering my own password for three hours.

    With Mixed Feelings (but probably a bit of love),

    - Largeboss

  • As our Quality Assistant already mentioned, if you have problems again, you must send a ticket to receive personalized assistance.

    To keep the section in order I proceed to close the thread.

    For any questions or comments please try to use the mp or Discord.



    Mod Elsword EN

    announcement_elsword_es_b1736064aefd126799915d9840f534ff.png Forum rules barra.jpg announcement_elsword_es_378ddbe60cd44b4a9e20bec098d2c59a.png Support barra.jpg announcement_elsword_es_0366c8f457e496446d223d590b845f3a.png Discord barra.jpg user.png T&C


    Soy una mujer. Puedo ser tan contradictoria como quiera.